Topic-icon Kunena zobrazuje ve zdroji pořád noindex, nofollow

  • Aplicator
  • Avatar uživatele Aplicator Autor tématu
  • Offline
  • Nováček
  • Nováček
Více
20. srp 2017 09:31 #344 od Aplicator
Aplicator vytvořil/a téma: Kunena zobrazuje ve zdroji pořád noindex, nofollow
Dobrý den,

mám problém, že ať udělám cokoliv, tak ve všech stránkách Kunena fóra mám pořád noindex, nofollow a to mám v globálním nastavení index, follow.

Jediné co mě napadá je, že je nějaký problém při žměně co jsem dělal, kdy jsem chtěl, aby ve stránkách Joomla bylo všude "index, follow" místo defaultního NIC. Provedl jsem tedy tuto změnu:

V souboru administrator/components/com_config/models/forms/application.xml a v něm upravte řádek 374 z původního
<option value="">JGLOBAL_INDEX_FOLLOW</option>
na
<option value="index,follow">JGLOBAL_INDEX_FOLLOW</option>

Díkes za nápady a rady

Prosím Přihlásit se nebo Vytvořit účet připojte se ke konverzaci.

Více
20. srp 2017 09:53 #345 od SEOmoucha
SEOmoucha odpověděl/a na téma: Kunena zobrazuje ve zdroji pořád noindex, nofollow
Ahoj,

zkus prohledat soubory v adresáři /web/components/com_kunena/controller na výraz nofollow, noindex a přidat za výraz
if ($robots == '')
{
	$doc->setMetaData('robots', 'index, follow');
}    
tuto podmínku:
elseif ($robots == 'index, follow')
{
	$doc->setMetaData('robots', 'index, follow');
}

do souborů, kde je nalezeno toto "nofollow, noindex"

Prosím Přihlásit se nebo Vytvořit účet připojte se ke konverzaci.

Více
20. srp 2017 11:10 #346 od SEOmoucha
SEOmoucha odpověděl/a na téma: Kunena zobrazuje ve zdroji pořád noindex, nofollow
Posílám náhled, jak je možné vyhledat text "index, follow" v souborech pomocí Total Commander a taky je to výpis těch, které je potřeba upravit.

Tato zpráva obsahuje přiložené obrázky.
Prosím, přihlašte se nebo se zaregistruje, pro jejich zobrazení.

Prosím Přihlásit se nebo Vytvořit účet připojte se ke konverzaci.

Přihlášení