check WEDOS | Warning: putenv() has been disabled for security reasons

  • Oko (Oko)
  • Avatar uživatele Oko (Oko) Autor tématu
  • Offline
  • Spammer
  • Spammer
Více
12. bře 2020 11:18 #464 od Oko (Oko)
Dobrý den,

mám webhosting u Wedos a po upgrade PrestaShop z 1.6 na 1.7 mi hlásí administrace chybu:
ContextErrorException | Warning: putenv() has been disabled for security reasons in Kernel.php line 122

Dávám to do Webhosting jelikož si myslím, že to nemá spojitost s PrestaShopem, ale s hostinggem.

Děkuji za rady.

Prosím Přihlásit se nebo Vytvořit účet připojte se ke konverzaci.

  • CMS systémy (cmssystemy)
  • Avatar uživatele CMS systémy (cmssystemy)
  • Offline
  • Expert
  • Expert
  • Všechny redakční systémy na jednom místě
Více
12. bře 2020 18:30 #465 od CMS systémy (cmssystemy)
Odpověděl CMS systémy (cmssystemy) pro téma WEDOS | Warning: putenv() has been disabled for security reasons
V souboru /vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php zakomentujte řádek:
putenv('SHELL_VERBOSITY=3');
takto:
// putenv('SHELL_VERBOSITY=3');

Vysvětlení je přímo na Wedos Help:
https://help.wedos.cz/otazka/problem-s-prestashopem-putenv-kernel-php/8056/

Tým CMS systémy

Prosím Přihlásit se nebo Vytvořit účet připojte se ke konverzaci.

Přihlášení